Download MCEdit for Mac OS X

Click one of the links below to download MCEdit 0.1.7.1 for Mac OS X. MCEdit is compatible with Mac OS X 10.6 (Snow Leopard) and up.

MCEdit requires X11 to run on Mac OS X. If your MCEdit closes immediately with an "MCEdit Error" dialog, downloading XQuartz will fix it. http://xquartz.macosforge.org/landing/


Development builds

Development builds are built from the latest master branch on GitHub every few days. These are cutting-edge releases and may contain a lot of work that is still in progress. Use with caution.


Header image by @DX_0Gamers